[Windmill-dev] Controller naming

Mikeal Rogers mikeal at osafoundation.org
Thu Oct 11 00:30:20 PDT 2007


Whoops, didn't hit reply all.

-Mikeal

On Oct 11, 2007, at 12:29 AM, Mikeal Rogers wrote:

>
> On Oct 10, 2007, at 11:37 PM, Adam Christian wrote:
>
>> Mikeal, the whole asserts thing is there and redundant due to a  
>> naming convention mde needed for developing the jsTests, we had a  
>> long debate about it and this really was the best solution..  
>> however at the moment I can't remember the details, mde?
>
> No, the solution was to do things like asserts.text, and mde was  
> going to point jum.assertsBlah stuff at the proper windmill asserts.
>
> We never agreed to bend the windmill controller naming convention  
> to look like xUnit.
>
>>
>> The waits.forNotTitle is useful because it allows you to provide a  
>> HTML title, and to wait until it changes to something else.. it's  
>> good for moving to a new page and we use it in the loading code to  
>> wait to set a listener until the testWindow title is no longer  
>> "Windmill Testing Framework"
>
> Ok, that totally makes sense, I was just really confused by the  
> name. Now that I look at it, it's not even the name, is that when I  
> read it he "Not" part stands out so much it confuses me. But  
> whatever, it totally makes sense after explaining it. Maybe I'll  
> update the WindmillBook to be a bit more descriptive.
>
>>
>> Adam
>>
>> On Oct 10, 2007, at 10:09 PM, Mikeal Rogers wrote:
>>
>>> I was looking through the controller documentation and noticed  
>>> some really nasty looking names.
>>>
>>> I know it's a pain in the ass to change these, but we've gotta do  
>>> this before we release 0.2 if we're going to do it.
>>>
>>> I've already committed to not making any public API changes until  
>>> 0.3, so this will have to go in tomorrow 0.2 before people invest  
>>> in them any more.
>>>
>>> http://windmill.osafoundation.org/trac/wiki/BookChapter-4- 
>>> WritingTests#AvailableMethods
>>>
>>> waits.forNotTitle -- maybe this one is fine, i just don't  
>>> understand it
>>>
>>> The entire assert namespace is redundant
>>> asserts.assertText -> asserts.text
>>> asserts.assertNode -> asserts.node
>>> asserts.assertValue -> asserts.value
>>> asserts.assertSelected -> asserts.selected
>>> asserts.assertChecked -> asserts.checked
>>> asserts.assertProperty -> asserts.property
>>> asserts.assertImageLoaded -> asserts.imageLoaded
>>>
>>> What does everyone else think?
>>>
>>> -Mikeal
>>> _______________________________________________
>>> Windmill-dev mailing list
>>> Windmill-dev at osafoundation.org
>>> http://lists.osafoundation.org/mailman/listinfo/windmill-dev
>>
>



More information about the Windmill-dev mailing list