[Windmill-dev] Controller naming
mikeal at osafoundation.org
Wed Oct 10 22:09:00 PDT 2007
I was looking through the controller documentation and noticed some
really nasty looking names.
I know it's a pain in the ass to change these, but we've gotta do
this before we release 0.2 if we're going to do it.
I've already committed to not making any public API changes until
0.3, so this will have to go in tomorrow 0.2 before people invest in
them any more.
waits.forNotTitle -- maybe this one is fine, i just don't understand it
The entire assert namespace is redundant
asserts.assertText -> asserts.text
asserts.assertNode -> asserts.node
asserts.assertValue -> asserts.value
asserts.assertSelected -> asserts.selected
asserts.assertChecked -> asserts.checked
asserts.assertProperty -> asserts.property
asserts.assertImageLoaded -> asserts.imageLoaded
What does everyone else think?
More information about the Windmill-dev