[Windmill-dev] Testing an autocomplete widget

Robert Leftwich windmill at rtl.fmailbox.com
Tue Dec 11 11:08:17 PST 2007


I'm evaluating Windmill for testing a largish web app, but unfortunately
I'm failing at the first hurdle. We use autocomplete from the YUI
library fairly extensively and I was wanting to test an instance of it,
but it seems that Windmill's 'type' method does not trigger the widget.
To simplify things I tried to test one of the examples on the YUI site -
http://developer.yahoo.com/yui/examples/autocomplete/ac_ysearch_json_clean.html
- but the autocomplete list of possible search queries never appears.
Following is the simplest test I recorded:

{"params": {"id": "ysearchinput"}, "method": "click"}
{"params": {"text": "windmill", "id": "ysearchinput"}, "method": "type"}

(I had other methods after the 'type' but they require the search query
list to be populated).

I've tried both the subversion and released versions of Windmill w/o
success.

Can anyone shed some light on this issue?

Robert

PS IIRC the last time I tried Selenium (which was some months ago) it
had a similar problem.


More information about the Windmill-dev mailing list