[pylucene-dev] How compile pyLucene on Solaris 10

Andi Vajda vajda at osafoundation.org
Sun Jan 6 17:39:19 PST 2008


On Sun, 6 Jan 2008, mario alejandro wrote:

> That is the part where I'm a noob.

Did you read the docs I pointed you at in my previous message ?
If so, what part makes you feel like a noob ?
If not, please read them :)

Which version of PyLucene are you trying to build ?
Which flavor, gcj-PyLucene or jcc-PyLucene ?
(see http://pylucene.osafoundation.org)

As for Solaris, to which I have no access, I really know nothing about the 
status of GCJ there. I strongly recommend you consider the JCC flavor of 
PyLucene which uses a sane VM and no GCJ but a C++ code generator I wrote to 
replace GCJ's CNI feature.

See http://pylucene.osafoundation.org for more information (as well as the 
links I sent you in my earlier message).

> Look at my attempts at
>
> http://discuss.joyent.com/viewtopic.php?pid=159014#p159014
>
> This is as far I go.

It looks like you're trying to build PyLucene 1.9.1, why ?
How about using something much newer that doesn't require SWIG or even GCJ 
such as http://downloads.osafoundation.org/PyLucene/jcc

>
> The SWIG compiler is working, but can't compile because complain about:

SWIG has not been a requirement for PyLucene for almost two years now (or is 
that three ?).

If you can, use PyLucene 2.2.0.

> find: cannot follow symbolic link /usr/lib/llib-lxnet: No such file or
> directory
> find: cannot follow symbolic link /usr/lib/llib-lxnet.ln: No such file or
> direct

Sorry, I don't know what these files are.

Andi..


More information about the pylucene-dev mailing list