[Dev] Switching to Ubuntu

Davor Cubranic cubranic at cs.ubc.ca
Sun Feb 19 13:00:18 PST 2006


Heikki Toivonen wrote:

>Mike Taylor wrote:
>  
>
>>Ubuntu (breezy) does not by default include 3.4 but that doesn't mean
>>it's not available.
>>    
>>
>
>I was unable to find it with Synaptic. Did you mean compile 3.4
>ourselves or tell Synaptic to look in Hoary's packages or something else?
>  
>
I already sort of responded in a different thread, but here are more 
specifics: on kUbuntu Breezy, Adept found gcc 3.4 no problem. The only 
repositories I had defined were breezy (main, restricted) and 
breezy-updates (main, restricted) on ca.archive.ubuntu.com/ubuntu.

Once installed, 3.4 is available as /usr/bin/gcc-3.4. /usr/bin/gcc is 
symlinked to 4.0. There is no executable called gccselect, although 
there may be another mechanism available to choose between installed 
version of the gcc toolchain.

Davor


More information about the Dev mailing list