[Dev] Wing IDE debugging problem

Donn Denman donn at osafoundation.org
Mon Dec 6 16:09:35 PST 2004


Ken,

Tell us more about how your Wing fails.  Does it launch?  Are you 
having trouble debugging?

Many of us run on Macs, and although we have seen some problems, it 
doesn't simply fail.

- Donn


On Dec 6, 2004, at 3:37 PM, Ken Krugler wrote:

> Hi all,
>
> I was having problems getting the debugger in Wing 2.0.0 to work with 
> Chandler. This is on Mac OS 10.3.6. Based on some logged output that I 
> sent them, Wing IDE Support said:
>
>> Thanks.  I'm guessing you ended up building Python 2.3.3 with the
>> --with-pydebug configuration option and we omitted support for
>> that in Wing 2.0.0 on OS X (by accident, as it turns out).
>>
>> If I'm right about that, you can either build the debugger against 
>> your
>> copy of Python (I can provide details if you choose to do this), 
>> change to
>> building w/o --with-pydebug, or wait until Wing 2.0.1 is released 
>> (which
>> will re-add the support for this compilation variant on OS X).
>
> Does this make sense? I'm curious as to why John's configuration 
> works, and mine doesn't. Though he was running against a release build 
> of Chandler, and I was using the debug build...could that have altered 
> the --with-pydebug setting?
>
> Thanks,
>
> -- Ken
> -- 
> Ken Krugler
> TransPac Software, Inc.
> <http://www.transpac.com>
> +1 530-470-9200
> _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
>
> Open Source Applications Foundation "Dev" mailing list
> http://lists.osafoundation.org/mailman/listinfo/dev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 1469 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/dev/attachments/20041206/f5980bbd/attachment.bin


More information about the Dev mailing list