[cosmo-dev] Performance?

Alan Lord alanslists at gmail.com
Thu Jan 3 03:08:31 PST 2008


Hi all and a Happy New Year,

As some of you know by now, I'm running a home built SVN (rev 6439) of 
Cosmo on my own Tomcat installation.

Cosmo works nicely most of the time, but after a "bit" of activity it 
seems to really load my server and almost grind to a halt.

TOP (I'm running Tomcat on Linux) reports around 99.5% CPU utilisation, 
sometimes I get the "Java Out of Memory" error but not always...

The platform is a VIA CN700 Processor @ 1.2Ghz with 1 Gig of RAM. I 
allow Java to have up to 900Mb in the startup script with:

JAVA_OPTS="${JAVA_OPTS} -Xms900m -Xmx900m -XX:PermSize=128m 
-XX:MaxPermSize=512m

although in "top" I never see more than about 350M taken by it.

I also have a CRM application running in tomcat from what was centric 
but is now called ConcourseSuite by Concursive Corporation. That seems 
to be quite happy all of the time.

Real useage is pretty low - only two/three users max, a few calendar 
collections and Cosmo is being accessed by Lightning, Cosmo's Web UI and 
sometimes the Chandler Desktop.

I realise the code is still not finished, as it were, but is there 
anything I can do to help track down the problem?

After a period of inactivity (10min or so) CPU useage drops back to very 
low levels (0.3% or so)... Unless we had the out-of-memory error. The 
only way to sort that out seems to be to restart tomcat.


Cheers

Al

-- 
The way out is open!
http://www.theopensourcerer.com



More information about the cosmo-dev mailing list