[Cosmo] More test weirdness

Brian Moseley bcm at osafoundation.org
Fri Feb 3 17:29:26 PST 2006


On 2/3/06, Heikki Toivonen <heikki at osafoundation.org> wrote:
> I've decurled hammer/creataccounts.py, but when I tested it against
> cosmo-test.osafoundation.org I found it does not work (got 403 I think).
> Assuming I broke something in the conversion I then tried the original,
> but I get the same results with the original. So I am wondering if this
> has ever worked, or if it is incompatible with whatever is at
> cosmo-test. It seems to work fine on localhost.

running the latest version of createaccounts.py from the trunk against
the cosmo 0.2.7 server on cosmo-test:8080:

bcm at cosmo-test:~/cosmo/src/test/hammer$ ./createaccounts.py -s
http://localhost:8080 -n 10 -f 350
Unhandled response code: 403

the access log says:

127.0.0.1 - - [03/Feb/2006:17:15:32 -0800] "PUT /cmp/user/test350
HTTP/1.1" 403 - "-" "-"

the url space for cmp in cosmo 0.2 is /api; in 0.3 that's been changed
to /cmp. that hasn't been reflected in the cmp documentation yet. i
plan to do that along with a bump in the cmp version. we also have
adding explicit version negotation to the protocol on the todo list.

your localhost build must be 0.3. makes sense.

perhaps a command line option on the hammer scripts that we can use to
signify whether we're talking to a "cmp 0.2" server or a "cmp 0.3"
one?

> I also did some more experiments with silmut, and noticed some
> differences between localhost and the remote cosmo-test. I don't know if
> these are expected. First, when I did a GET for /home/test1 on
> cosmo-test, it replied with 302, pointing to /home/test1/ (200 if I
> originally pointed to /home/test1/). On localhost I get 401 for both
> forms. One difference at least is that I am running Windows XP on localhost.

sounds like the /home/test1 -> /home/test1/ redirection bug fix didn't
make it to the trunk. i'll figure that out, thanks.



More information about the Cosmo mailing list