[chandler-users] Hub possible fix

Jared Rhine jared at wordzoo.com
Tue May 5 15:02:47 PDT 2009


On Monday 04 May 2009 13:20:01 Jared Rhine wrote:
> A variety of people have reported the distressing problems with Hub
> throwing 400 errors and similar looking errors.

In reprocessing older bug reports, I (re-)found where the "maybe its the JVM" 
idea came from:

  https://bugzilla.osafoundation.org/show_bug.cgi?id=12291

Randy, in processing this bug, set an option on the server to "avoiding 
optimizing TicketAuthenticationProvider".  I found this configuration in the 
files for "hub-29", the previous version of the Hub production instance, but 
it's not in "hub-30", the production instance that Jeffrey pushed live Feb 
13th.

So I confirmed I could replicate two bugs, 12291 and the "editing a description 
throws a 404".  Then I made the "avoid optimizing 
TicketAuthenticationProvider" change to hub-30 (the live Hub) and now those 
two bugs are working.

So huzzah, probably!

People who have had problems with the Hub throwing errors, could you please 
repeat your tests and update bugs you have filed about Hub edit/save problems?

There are probably still issues remaining, but we need to collectively figure 
out which ones.  As the above description suggests, this fix may have affected 
the general category of ticketing-related errors.  (Though "just edit the 
description" is also fixed for me and that's not ticketed.)

-- Jared



More information about the chandler-users mailing list