[chandler-users] Installing chandler on Ubuntu 64 bit

Davor Cubranic cubranic at cs.ubc.ca
Sun Feb 8 21:07:20 PST 2009


That's because the included icu library is compiled for 32-bit systems. 
I ran into the same problem (albeit with the tar file, not the deb) and 
solved it with 'getlibs', which identifies and installs compatibility 
packages needed to run a given executable. I'd imagine it will work 
even better with .deb packages because those explicitly declare all 
dependencies.

You can download getlibs from 
http://www.boundlesssupremacy.com/Cappy/getlibs/getlibs-all.deb and 
install it with 'dpkg -i getlibs-all.deb'. In my case, I then switch to 
the directory where I unpacked chandler's tgz file and 
run 'getlibs ./chandler'. You may want to check its documentation (or 
the thread on Ubuntu forums: 
http://ubuntuforums.org/showthread.php?t=474790) to see whether it's 
run differently in the case of .deb packages.

Davor


On Sunday 08 February 2009 14:17:02 Andrea Francia wrote:
> Hello, everybody.
>
> I had some problems installing chandler on my 64 bit Ubuntu.
> I'm interested to know how other peoples solved this problem.
>
> I dowloaded Chandler_linux_1.0.2-1_i386.deb from [1].
> The I installed it with
>
>    dpkg -i --force-architecture Chandler_linux_1.0.2-1_i386.deb
>
> But when I ran chandler I got the following:
>
> -------8<-------------------------------------
>    andrea at oleandro ~/D/chandler> chandler
> Traceback (most recent call last):
>   File "Chandler.py", line 21, in <module>
>     from application import Globals, Utility
>   File "/usr/lib/chandler/application/Globals.py", line 24, in
> <module> from application.Utility import initDefaults
>   File "/usr/lib/chandler/application/Utility.py", line 21, in
> <module> import i18n, schema, itertools
>   File "/usr/lib/chandler/i18n/__init__.py", line 16, in <module>
>     from i18nmanager import I18nManager, I18nException
>   File "/usr/lib/chandler/i18n/i18nmanager.py", line 20, in <module>
>     from PyICU import Locale
>   File
> "/usr/lib/chandler/release/site-packages/PyICU-0.8-py2.5-linux-i686.e
>gg/PyICU.py", line 38, in <module>
>   File
> "/usr/lib/chandler/release/site-packages/PyICU-0.8-py2.5-linux-i686.e
>gg/_PyICU.py", line 7, in <module>
>   File
> "/usr/lib/chandler/release/site-packages/PyICU-0.8-py2.5-linux-i686.e
>gg/_PyICU.py", line 6, in __bootstrap__
> ImportError:
> /home/andrea/.python-eggs/PyICU-0.8-py2.5-linux-i686.egg-tmp/_PyICU.s
>o: wrong ELF class: ELFCLASS32
> -------8<-------------------------------------
>
> So, to work around I built it from sources, but I'm not satisfied by
> this solution because I would prefer install it through a .deb
> package.
> This problem happened to someone else that me? How do you solved it?
>
> Thanks
>
> [1]
> http://downloads.osafoundation.org/chandler/releases/1.0.2/#enduserli
>nux


More information about the chandler-users mailing list