[chandler-users] A few bugs and issues

Travis Vachon travis at osafoundation.org
Wed May 21 18:50:24 PDT 2008


Ah, actually, after a quick peek at the web ui, a couple thoughts  
about both questions


>
> ------------------------------------------
> Biggest Issue - Sharing Collections
> ------------------------------------------
> BUG #1: The first bug here is that when you choose invite, you only  
> see the view-and-edit
> link, there is no view-only link.
>
> BUG #2 ?: When I send that link to another user, and they try to  
> subscribe, the server
> returns a 403, and a rather large XML message about insufficient  
> privileges. I put a
> question mark on this, since it may be a privilege setting that I do  
> not know how to find,
> rather than a bug. (If you want/need the XML message, I'll dig it up  
> for you).
>

How is your server configured? Are you running behind an apache  
reverse proxy? If so, you'll need to make sure you've specified  
reverse proxy settings in the appropriate spots:

http://chandlerproject.org/Documentation/ServerBundleReverseProxy

Depending on the answer, this could potentially be the cause of both  
problems.

  It would help to diagnose the specific problem you're having it you  
could paste the link you're being given (the one returning the 403).  
If security is a concern, feel free to replace the uuid (the long  
string of the form xxxx-xxxxxxx-xxxx.. etc) and the ticket key.

In general, make sure to read through

http://chandlerproject.org/Developers/ServerBundleAdministrator

if you haven't already, as it covers a number of possible pain points.

Thanks again,

-Travis


More information about the chandler-users mailing list