[chandler-users] Desktop: Can't publish collection

Grant Baillie grant at osafoundation.org
Fri Aug 29 18:11:09 PDT 2008


Hi, Keith

I would export your data to a .chex file and reload it. The repository  
appears to have some weird data in the history of one of your items,  
and reloading it should flush the history and clear that up.

--Grant

PS: I'll take a look at the single item not syncing issue, too.

PPS: As you noticed, upgrading Chandler on Windows doesn't change the  
name of the installation directory. I'm not au courant enough with  
Windows installer scripts to know how to fix that :(.

On 29 Aug, 2008, at 17:18, Keith Winsor wrote:

> Win XP, Chandler desktop 1.0.
>
> I have eleven collections shared via Chandler hub. I've created  
> another collection but whenever I try to publish it I get the  
> following traceback:
> Traceback: <class 'chandlerdb.persistence.c.DBError'>: (14, 'Bad  
> address')
> C:\Program Files\Chandler0.7alpha5\release\bin\lib\site-packages 
> \twisted\python\threadpool.py:148:_worker
> C:\Program Files\Chandler0.7alpha5\release\bin\lib\site-packages 
> \twisted\python\context.py:59:callWithContext
> C:\Program Files\Chandler0.7alpha5\release\bin\lib\site-packages 
> \twisted\python\context.py:37:callWithContext
> C:\Program Files\Chandler0.7alpha5\util\task.py:88:__threadStart
> --- <exception caught here> ---
> C:\Program Files\Chandler0.7alpha5\release\bin\lib\site-packages 
> \twisted\internet\defer.py:107:maybeDeferred
> C:\Program Files\Chandler0.7alpha5\application\dialogs 
> \PublishCollection.py:451:run
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing\__init__.py: 
> 518:publish
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing\cosmo.py: 
> 111:publish
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing\shares.py: 
> 797:put
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing\shares.py: 
> 778:sync
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing\cosmo.py: 
> 333:sync
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing 
> \recordset_conduit.py:86:sync
> C:\Program Files\Chandler0.7alpha5\parcels\osaf\sharing 
> \recordset_conduit.py:404:_sync
> c:\program files\chandler0.7alpha5\release\bin\lib\site-packages 
> \chandlerdb-0.7_37-py2.5-win32.egg\chandlerdb\persistence 
> \DBContainer.py:1299:iterHistory
> c:\program files\chandler0.7alpha5\release\bin\lib\site-packages 
> \chandlerdb-0.7_37-py2.5-win32.egg\chandlerdb\persistence 
> \DBContainer.py:1287:next
> The other collections still sync happily, so it doesn't seem to be a  
> connection issue. Can anyone offer any suggestions, please?
>
> Also, any takers for last week's post re a collection where a single  
> item will not sync?
>
> Many thanks,
>
> Keith
>
> PS It's definitely 1.0 - notwithstanding the 0.7alpha5 folder!
> _______________________________________________
> chandler-users mailing list
> chandler-users at osafoundation.org
> http://lists.osafoundation.org/mailman/listinfo/chandler-users



More information about the chandler-users mailing list