[chandler-users] Using Plugins

Scott Dubose scott.dubose at gmail.com
Mon Aug 18 22:43:06 PDT 2008


Thanks Grant, that worked.

On Mon, Aug 18, 2008 at 12:20 PM, Grant Baillie wrote:

> Hi, Scott
>
> The "Install Plugin" menu item is broken on the Mac. If you're comfortable
> using a Unix shell, it should still be possible to install plugins via:
>
> <<quit chandler>>
>
> cd /Applications/Chandler_intel-osx-leopard_1.0.app/Contents/Resources
> ./release/RunPython ./release/InstallPlugin <<path to plugin>>
>
> As a caveat, though, the plugins are mostly in a pretty rudimentary state.
> I'll double-check today which plugins do in fact work on 1.0 (for example, I
> believe the debug plugin does), and update readme files and/or new versions
> as appropriate.
>
> --Grant
>
>
> On 16 Aug, 2008, at 11:50, Scott Dubose wrote:
>
>  Hello,
>>
>> I'm getting errors trying to install plugins but I'm not sure if this is a
>> user error or something worthy of bug report. I'm a database guy and windows
>> programmer but new to Chandler, and programming in the OSX environment. I'm
>> running Version 1.0 for Mac OS X (intel), for Leopard. I've tried various
>> plugins from the python site. After running install from the menu and point
>> it to the plugin, chandler shuts down. On restart, no plugins are listed
>> Plugins->Active menu.
>>
>> Could it be that none of the plugins are compatible with the current
>> version of chandler because of their version numbers (all are < 1.0).?
>>
>>
>> The errors from the console are:
>> Aug 16 11:39:47 Macintosh-5
>> [0x0-0x3a03a].Chandler_intel-osx-leopard_1.0[433]: Usage: Chandler.py
>> [options]
>> Aug 16 11:39:47 Macintosh-5
>> [0x0-0x3a03a].Chandler_intel-osx-leopard_1.0[433]: Chandler.py: error: no
>> such option: -E
>> Aug 16 11:39:47 Macintosh-5
>> [0x0-0x3a03a].Chandler_intel-osx-leopard_1.0[433]: error: command
>> '/Applications/Chandler_intel-osx-leopard_1.0.app/Contents/MacOS/ChandlerApp'
>> failed with exit status 2
>>
>> and the Chandler log:
>> <osaf.sharing.WebDAV.ChandlerHTTPClientFactory instance at 0x1df8b788>
>> 2008-08-16 01:54:58,455 osaf.app.updates INFO: No version newer than '1.0'
>> found
>> 2008-08-16 01:55:13,432 twisted WARNING: Stopping factory
>> <osaf.sharing.WebDAV.ChandlerHTTPClientFactory instance at 0x1df8b788>
>> 2008-08-16 01:58:06,660 application.Plugins INFO: running easy_install
>> 2008-08-16 01:58:06,668 application.Plugins INFO: Checking .pth file
>> support in
>> /Applications/Chandler_intel-osx-leopard_1.0.app/Contents/Resources/plugins
>> 2008-08-16 01:58:06,668 application.Plugins INFO:
>> /Applications/Chandler_intel-osx-leopard_1.0.app/Contents/MacOS/ChandlerApp
>> -E -c pass
>> 2008-08-16 01:58:07,838 stderr WARNING:
>> 2008-08-16 01:58:08,644 repository INFO: closed db in 0:00:00.803524
>>
>> 2008-08-16 02:01:49,508 application.Utility WARNING: === logging
>> initialized,
>>
>> Thanks,
>> Scott
>> _______________________________________________
>> chandler-users mailing list
>> chandler-users at osafoundation.org
>> http://lists.osafoundation.org/mailman/listinfo/chandler-users
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osafoundation.org/pipermail/chandler-users/attachments/20080819/fa4790a2/attachment.htm


More information about the chandler-users mailing list