[chandler-users] Install ioctl problem on Mac

Will Woods will.woods at ynic.york.ac.uk
Thu Aug 7 06:59:47 PDT 2008


Yes, it is - and the other account I tried it on (which worked) was on the local 
drive. COuld that be the problem, and is there a fix?

Will


Grant Baillie wrote:
> 
> On 7 Aug, 2008, at 03:01, Will Woods wrote:
> 
>>
>> When I try and run Chandler for the first time, I get an error 
>> 'Inappropriate ioctl for device'. If I log in to the same machine as a 
>> different user, it runs ok, so I guess it might be something to do 
>> with permissions on my account. Any ideas? Full log is below.
> 
> Hi, Will
> 
> Is your home directory on a network drive?
> 
> --Grant
> 
>> ...
>>  File 
>> "/Applications/Chandler_ppc-osx_1.0-rc2.app/Contents/Resources/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/chandlerdb-0.7_37-py2.5-macosx-10.3-ppc.egg/chandlerdb/persistence/DBRepository.py", 
>> line 909, in open
>>    self._env.open(dbHome, flags, 0)
>> DBError: (25, 'Inappropriate ioctl for device')
> 

-- 

Will Woods

York Neuroimaging Centre
The Biocentre
York Science Park
Innovation Way
Heslington
York
YO10 5DG

http://www.ynic.york.ac.uk


More information about the chandler-users mailing list