[chandler-users] Is there any plugin that will work with recent Chandler version?

Andi Vajda vajda at osafoundation.org
Fri Apr 4 10:53:50 PDT 2008


On Fri, 4 Apr 2008, Andi Vajda wrote:

> On Thu, 3 Apr 2008, Carl Lemp wrote:
>
>> Since the last time I tried the debug plugin it killed Chandler, I just 
>> uninstalled, then reinstalled Chandler and tried again.  When Chandler goes 
>> to the CheeseShop and lists the plugins, it lists two entries now for the 
>> debug plugin.  Only one entry has a link to an archive file that the 
>> Plugins/Download menu recognizes.  However, using the Install menu item 
>> after downloading results in a traceback just like it used to.  The other 
>> entry in the cheeseshop has a reference to a command line command to 
>> install the plugin but that doesn't work under Windows. Is there a way to 
>> download and install the debug plugin under windows?
>
> Indeed, there were two entries for the Chandler-debugPlugin on cheeseshop. 
> One was obsolete (version 0.2) and should have been hidden. I just fixed 
> that. The other one, apparently for version 0.7.5, was missing its source 
> archive. I just fixed that too.

I just downloaded Chandler 0.7.5.1 for Mac OS X Intel and installed the 
debug plugin from cheeseshop. All seems to work fine.

Here is what I did:

   - download and install chandler 0.7.5.1 from OSAF's site
   - copy Chandler.app to my desktop
   - started it
   - picked Plugins -> Download, my browser opened at the cheeseshop page
   - I downloaded the source archive for the Chandler-debugPlugin 0.7.5
   - went back to chandler and picked Plugins -> Install
   - navigated to my browser's downloads dir and picked the archive
     downloaded for Chandler-debugPlugin 0.7.5
   - after a few seconds, the menu items for the plugin became available
     under various top level menus such as Tools.

This is how it is supposed to work for all other plugins provided they're 
current with the version of chandler you're using which can be iffy on 
Cheeseshop if you pick a plugin whose version is less than the version of 
Chandler you're using.

Andi..


More information about the chandler-users mailing list