[Chandler-dev] Bugs 10906 and 10989: Chandler on Gutsy

Robin Dunn robin at alldunn.com
Fri Oct 12 21:05:12 PDT 2007


Robin Dunn wrote:
> I upgraded my Ubuntu VM to Gutsy to test the new version of wxPython and 
> verify that bugs 10906 and 10989 are fixed.  They are fixed, but I am 
> getting a new crash that I don't understand.  In the debug build if I 
> start Chandler with the --create option then it starts up okay and all 
> appears to run well, but without --create it will segfault shortly after 
> the splash window is shown.  Based on the gdb backtrace it appears it is 
> crashing in Python while it is importing modules from twisted.  If I run 
> the release build it works fine.  I know there was a --create related 
> issue with the new WingIDE last week, and although this seems to be the 
> opposite (crashes without --create instead of with it) I'm hoping that 
> this will ring a bell for someone.  Any ideas what would be different 
> between --create and not --create that could trigger a problem like 
> this?  I've tried with new clean builds of Python and wxPython with no 
> change.

I discovered that I'm having the same problem on my Feisty machine too, 
and I realized that my chandler dir on that machine may not have been 
fully updated when I tested before.  So I worked backwards in SVN and 
discovered that this crashing problem with the new wx starts with 
r15394.  Before that the debug linux version runs fine, including the 
full functional tests.  Andi, that was the rev that merged the lucene 
branch into trunk.  Any ideas?


-- 
Robin Dunn
Software Craftsman
http://wxPython.org  Java give you jitters?  Relax with wxPython!



More information about the chandler-dev mailing list