[Chandler-dev] Compiler versions

Reid Ellis rae at osafoundation.org
Wed Apr 19 21:23:26 PDT 2006


On Wed Apr 19 2006, at 23:48, Heikki Toivonen wrote:
> 1. By default, only print out a warning about potentially  
> incompatible compiler but continue to build anyway. If  
> CHANDLER_STRICT_BUILD_ENVIRONMENT_CHECK was defined, the build  
> would actually stop with an error.

+1

gcc version problems are not limited to the Mac. I realize we never  
really said this in IRC today, but I thought I should point it out.

Ubuntu has similar problems. As I am running Dapper Drake, my gcc is  
v 4.0. I will install gcc-3.3 and gcc-3.4 and try them.  
Unfortunately, I don't think Ubuntu has anything like gcc-select to  
choose a global default gcc version. Perhaps just manually changein  
the symlink for /usr/bin/gcc will do?

Reid



More information about the chandler-dev mailing list